Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Have a 2013 DC longbed. 5.7. Almost 2500 mi. Every time I turn off the motor there is a very noticeable reving of what sounds to me like a pump of some sort. The truck runs fine seems to drink alot gas but this sound just does not seem to be something that anyone would have designed this way. Do they all make this sound?
 

·
Registered
Joined
·
408 Posts
its normal.
 

·
Registered
Joined
·
11 Posts
Yep just picked up my new 13 the other day and I noticed the same thing. Doesn't seem to be a problem.
 

·
"BHLM Master"
Joined
·
3,232 Posts
Might be the fuel pump sending unit taking one more big sip before retiring from yet another day of drinking, lol- I don't have the noise issue on my 2009- Joe
 

·
Premium Member
Joined
·
288 Posts
I recently noticed it, too. Sounds like a motor spinning for about a second. I wonder if this could have anything to do with the recall which flashed the ECM. Any thoughts?:confused:
 

·
Premium Member
Joined
·
288 Posts
That's exactly it...did you see my post above?

Sent from AutoGuide.com App
Thanks. I overlooked your post because I was looking for ECM recall and flash. Maybe the dealer should tell us this stuff. I wonder how many people call the dealer about this noise?
 

·
Registered
Joined
·
761 Posts
I'm glad I found this thread. I just went in last weekend for my 5000 mile service and they did the recall reflash thing...there is definitely a new sound now when shutting the truck off. I am not worried anymore after seeing this and hopefully it takes care of the AIP thing. :)


Sent from AutoGuide.com App
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top