Toyota Tundra Discussion Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
65 Posts
Discussion Starter · #1 ·
I've had Firestone Airbags on my 2012 CrewMax for 8 months (2 days after purchase) trouble free. 12 Days ago I had had 5000 Mile Maintenance and tire rotation, etc. 9 days ago VSC engaged going around a subtle curve in the road at 40mph for no reason (dry 70 degree dirt free pavement road). 5 days ago it did again at 50mph. I called the dealership and brought it in for maintenance. They reproduced the situation on an on-ramp to a highway and told me it was VSC engaging. The mechanic put it on a lift and called me out because they wouldn't do anything further until my Firestone Airbags were removed. They removed them and claimed that they weren't able to reproduce the problem afterwards. I tow frequently so I had them put airbags back on. A Toyota regional mechanic stopped by and looked at it too. They've registered my vehicle as having mechanical issues with suspension and traction control.

Any ideas why VSC suddenly engages and has anyone had problems with Firestone Airbags? I can't find any issues reported....

Thanks in advance for any feedback.
 

·
Read Only
Joined
·
0 Posts
Need more info... Do you have a level kit on it too? If you do all you will need to do is the zero point calibration.
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #3 ·
I do not have any type of aftermarket suspension components. When I added the Firestone Airbags 2 days after taking truck off dealership lot I did add a rear TRD Sway Bar. Other than that, nothing else added/removed. I only keep about 5 pounds or so of air in the airbags when i'm not towing.
 

·
Premium Member
Joined
·
3,545 Posts
I'm not real familiar with the bags, but can't you lower the pressure when you are not towing? Lose some air pressure and test.

Report back, I am interested.

KO
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #5 · (Edited)
When you aren't towing you deflate airbags from 110lbs max to 5-10lbs for every day (essentially they do nothing at 5-10lbs (just have enough air in there to maintain seals and such i guess.
 

·
Registered
Joined
·
530 Posts
My truck had 3" of take stock, so with the added 1" or so of lift from the bags, your looking at 4" of rake? Level the front, problem solved.
 

·
Registered
Joined
·
20 Posts
having same issues its not the bags....they are working on my truck with toyota engineers. mine is a stock 2013 RockWarrior Crew same problem in sweeping turns...VSC or abs is activating sounds like there is something whining and grinding in front end that your turning from....stay tuned brother
 

·
Registered
Joined
·
65 Posts
Discussion Starter · #8 ·
"Miraculously", after an ECU upgrade and taking the battery cables off for 10 minutes afterwards, the problem seems to be gone. Haven't had a problem since I originally posted. Who knows which fixed the problem. Stealership still blames airbags! Give me a line that the airbags being removed and then put back on is also a "change" that might have "fixed" it. They can't explain how putting them back on exactly same way is a "change" though.... I'm afraid that something with rotating tires changes the stance and the sensors with the rake of the truck. If it happens again, I guess taking battery cables of is option 1 and asking them to zero out the truck level is option 2 if my hypotheses is correct. Frustrating frankly.

Good luck and post back what they find with your truck!
 

·
Registered
Joined
·
408 Posts
I had my tires rotated and ecu upgrade and BAM same thing! WTF?! I did ZPC and adjusted tire pressure which has seemed to work, so far.....
 
1 - 9 of 9 Posts
Top