Toyota Tundra Discussion Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
143 Posts
Discussion Starter · #1 ·
I've tried to search for this and come up empty. I just put on a undercover SE tonneau cover. Every time I hit a bump I hear a rattle near the cab and its very annoying. It's almost like the cover is bouncing on the bed. My dads tundra with the under cover classic doesn't do this but it's 3 years old. I notice if I lift on the cover near the cab it pulls up half a inch or so. My Dads classic does not move at all. Any else hear anything about these covers rattling?
 

·
Registered
Joined
·
16 Posts
Are you sure the tonneau is where the rattling is coming from? Whenever I had my rear window down on my crewmax I could hear a rattling every time I hit a bump and could not for the life of me figure out what it was... then I put down the tailgate and noticed the cable latch screw was a bit loose. Tightened it up and voila, no more rattle. Double check.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #3 ·
Are you sure the tonneau is where the rattling is coming from? Whenever I had my rear window down on my crewmax I could hear a rattling every time I hit a bump and could not for the life of me figure out what it was... then I put down the tailgate and noticed the cable latch screw was a bit loose. Tightened it up and voila, no more rattle. Double check.
I'm pretty sure it's coming from that part of the tonneau. I know it was not making the noise before I put the cover on. Truck is new with only 1500 miles so far. I'll check the cables also though.
 

·
Registered
Joined
·
297 Posts
You put the wife in back with a wrench and drive around until she finds the rattle. Problem solved.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #5 ·
You put the wife in back with a wrench and drive around until she finds the rattle. Problem solved.
Haha i thought about doing that too.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #6 ·
Here are some videos of what I'm talking about. I doubt it moves this much while driving but it'll give you a idea of what I'm talking about.
 

·
Registered
Joined
·
402 Posts
You have the screw knobs tightened down into the lift bracket? Doesnt look like you do because mine doesnt do that.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #11 ·
Here's a picture with it opened.
 

Attachments

·
Registered
Joined
·
143 Posts
Discussion Starter · #12 ·
The only thing that moves are the hinges. The brackets don't move it all. Seems like there should be something to stops it from moving up on the front.
 

·
Registered
Joined
·
402 Posts
Is your front mount that mounts to the side of the bed tight? Thats all I can think of. My moves up a little bit but not as much as yours.
 

·
Registered
Joined
·
143 Posts
Discussion Starter · #14 ·
Is your front mount that mounts to the side of the bed tight? Thats all I can think of. My moves up a little bit but not as much as yours.
Ya I just tried different adjustments forward and more back too see it changed anything. Nothing changes but all the bolts are tight to the point the bracket started to bend. Both brackets aren't moving at all just the hinges. I sent a email to undercover along with the video so we will see.
 
1 - 14 of 14 Posts
Top