Toyota Tundra Discussion Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I am having a very weird situation with my 14 Tundra Limited 4x4 with a 3/2 leveling kit and the truck has 131,000 miles. I recently had the steering rack replaced and when I got it back the truck developed a hissing type noise. So I thought since I had just had the rack replaced, my first thought was that I damaged the power steering pump limping it to the shop. So I had that replaced and it still has the same noise, so it wasn't the power steering pump pulley.

It only squeals when running and the steering wheel is not being turned. When I accelerate it doesn't get louder, and when I turn the wheel it seems to be functioning perfectly. The noise does occur when I am both in park and in drive. My thinking is that by moving the wheel I am putting tension on the belt due to the power steering pump engaging. I changed the belt a couple years ago (90,000 miles) to a Gates belt. I have looked all over the internet and have not seen anyone describe the problem that I am having.

From my investigation the bulk of the noise is coming from the drivers side wheel well area. Could it be the compressor clutch/pulley bearing? The noise does not appear to be affected by if the a/c is running or not. I also don't think it is coming from the idler pulley, but I have also not pulled the belt and checked that pulley yet. The belt tensioner pulley does not appear to be making noise either, but I don't know if it is holding proper tension on the belt.

The video below is not of my truck, but my truck is doing the exact same thing.


Sorry if the story and examples are hard to follow, I have been researching like crazy and am extremely frustrated. Again, the weirdest part is that the noise goes away when I move the steering wheel. Any help would be greatly appreciated, I would like to avoid spending even more money on things are not going to fix the problem. Right now it seems like I am just guessing at solutions at this point.

-Brandon
 

·
Registered
Joined
·
546 Posts
Are you sure the belt is routed correctly? It’s possible to route it 2 ways...one way is correct, one way is not.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
It ended up being a bad power steering rack. I had it replaced again and the noise has gone away.
 

·
Registered
Joined
·
35 Posts
thanks for the update there OP. i know for sure you were frustrated for awhile but glad it was just something you had to replace instead of "living with the issue". i have seen too many times online people just sludging through issues like that to avoid fixing it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I appreciate that, I am very fortunate that the part and labor were covered under a warranty. I really wanted to give everyone a resolution. The worst thing is when people don’t post what the actual fix was.
 
1 - 7 of 7 Posts
Top