Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Got a problem. When I plug anything into any one of the 3 power ports the reception on my stock radio goes to crap and static. I have had to have them replace the fuse on the power ports 3 times. It keeps blowing the 15 amp fuse. Any one had this problem or have suggestions?
Billy
 

·
Premium Member
Joined
·
2,962 Posts
So are you saying the cell phone charger causes the radio interference or takes out the fuse?

Did you buy your truck new? If purchased used, then someone may have something else connected to that circuit.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Dealer said it was my cell phone charger causibg the radio issue. Going to ask another dealer...I always thought the power plug circuit and the radio circuit were two different circuits each on its own fuse. Am I wrong?
 

·
Registered
Joined
·
2 Posts
Got a problem. When I plug anything into any one of the 3 power ports the reception on my stock radio goes to crap and static. I have had to have them replace the fuse on the power ports 3 times. It keeps blowing the 15 amp fuse. Any one had this problem or have suggestions?
Billy
I had this problem. The NSA had a satellite track on my phone, so every time I plugged my phone up, radio interference surged in order to relay the signal and get a better pinpoint on my location, as well as pick up all audio inside the trucks Bluetooth system. I switched to a low grade burner phone and everything is fine now. Good luck👍
 
1 - 11 of 11 Posts
Top