Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Read Only
Joined
·
0 Posts
Discussion Starter · #1 ·
I am attributing this to the 3/1 or the new rack and pinion. Any ideas? Sounds like its coming from the front.... Could also be the leaf packs. I swear im thinking about parting it out and trading for a Duramax or something. First it was the cam tower oil leak, then the rack and pinion... Now this unholy freaking squeaking when I go over bumps. Went to a horse barn where my wife bought a horse yesterday. I was embarrassed as crap l. Sounded like a clunker. Sorry for the rant. Its been a rough week.
 

·
Registered
Joined
·
13,893 Posts
look at my squeak vid posted in a rack failure thread... Does it sound like that?
 
  • Like
Reactions: Mr. Creosote

·
Read Only
Joined
·
0 Posts
Discussion Starter · #3 ·
Kinda.... Mines not doing it with turning the wheels though. Just over rough or bumpy roads. Mine not as loud as yours either.
 

·
Registered
Joined
·
52 Posts
check your lower ball joints, it seems to be a pretty common part failure on tundras with a 3/1. my drivers side ball joint is going on mine with 77000 kilometers, 3/1 was installed at about 25000 but i started noticing the squeak quite a while ago.
 
  • Like
Reactions: Mr. Creosote

·
Registered
Joined
·
13,893 Posts
Mine started out quiet.

Oddly enough, today it magically went away.

Fuhg... Now I guess at least I have video of it being fubar...

I don't get it.
 
  • Like
Reactions: Mr. Creosote

·
Read Only
Joined
·
0 Posts
Discussion Starter · #8 ·
I did go drive a duramax, and a new Denali 1500. Believe I'll keep my truck. That Denali was still nice as I remember, but not worth 54K. The 6.2L sounds awesome stock and runs good though, but the AWD takes more power so I think the Tundra is still just as quick if not slightly faster.
 

·
Premium Member
Joined
·
3,044 Posts
I've got a squeak like that going on too and I'm going insane. I'm dropping it off at the dealership in Tuesday to have ten look at it. I have bilstein 5100s at their top setting and I've only run them for about 10,000 miles. Makes me feel like I'm driving a pile :/


Sent from AutoGuide.com App
 
  • Like
Reactions: Mr. Creosote

·
Read Only
Joined
·
0 Posts
Discussion Starter · #10 ·
well turns out mine was the loose stroller in the bed. drove it on a 200 mile round trip yesterday evening and not the first squeak.
 

·
Read Only
Joined
·
0 Posts
Discussion Starter · #11 ·
Ok so its still squeaking. It wasn't doing this before the new rack went in, and its very minor now without the stroller making extra noise. Gonna crawl around under it and see what I can find soon. If nothing is found it'll be going to the dealer to make them find it and fix it.
 
1 - 11 of 11 Posts
Top