Toyota Tundra Discussion Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
So just bought my 2013 Crew Max Tundra with 14,800 Miles on it. Tire light came on the 2nd day I bought it so I took it into Les Schwab and they couldn't find anything wrong. Light stays on, get in my truck this morning and Mait Req light flashes then disappears. During my drive this morning to work the oil pressure gauge was going up and down. About 3/4 to 1/2 while i accelerated and down when i was coasting. I have an apt today from the dealership, should I be worried about all these problems and only owning the truck for 5 days?
 

·
Registered
Joined
·
238 Posts
I would be worried about your dealer. Your first issue needs more details. Did you or they check the pressure? Did you or they reset it? Doesn't really make much sense that you would take it in for that and they give it back with the light still on with and say nothing wrong.
 

·
Registered
Joined
·
238 Posts
As far as the Maintenace light, when was the last oil change and was it reset? The light will start flashing when you are within 500 miles of needing a change.
 

·
Registered
Joined
·
582 Posts
Those tire pressure sensors are a PITA...have them replace it under warranty and be done.

The oil pressure irregularity is more worrisome for obvious reasons.

Frank
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Had Les Schwab check the tire light. Said all the psi was normal in four tires and the spare so they didn't know why the light was staying on. It just had an oil change at 13,000 Miles so not sure why the required light if flashing. Taking it in today and hopefully nothing too crazy. Have had the truck for 4 days and already been back twice for issues...
 

·
Premium Member
Joined
·
456 Posts
Thread drift.
When you do the ignition / trip for maintaince reset I pressume it resets the light for 5000 miles until the 4500 mile warning flash.

When you go to the maintenance section of entune how do those parameters work that you can edit in the field values
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
Here's an update...So they put me in a rental tundra last night. Seems like the guy who had it before (Maintenance Tech Guy at Toyota) had TRD Tires on there and switched back to factory tires before selling (Bummer) so it messed with some of the sensors. They told me the oil pressure gage is normal, and after reading a bit on this forum it seems to happen quite a bit so guess i'm not too worried about it. Thanks for all the responses
 
1 - 7 of 7 Posts
Top