Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
I just installed my 35w hid kit from the retrosource.i decided on them after reading some of the reviews on here. they start right up ever time without any problems. I am gonna install the relay harness for added peace of mind. I like the 5 year warranty they offer
 

·
Premium Member
Joined
·
267 Posts
I also have the morimoto 3Five ballast/bulbs w/harness and the mini morimoto projectors, and I have been nothing but satisfied. I can't stop looking at my headlights after I get out of the truck. Great kit.
 

·
Registered
Joined
·
90 Posts
Thumbs up for Matt and Carlos at TRS. Great customer service even when the customer messes up.

The Morimoto kits are good for the money you spend. I recommend the 5k xb35 to get closer to white. The 4.3k seemed too yellow. If you are using the 55 watt ballast they drive the bulbs harder so I would probably gor for the 6k even.
 

·
Premium Member
Joined
·
267 Posts
I too have the Morimoto kit (Morimoto mini projectors, bulbs, ballasts and relay harness), purchase from TRS, I've been running this kit for almost 2 yrs now.

I routinely have issues with either headlight randomly failing to fire/light at engine start-up esp when temps drop. After further research I have come to find out I am not alone - similar problems reported on the Porsche owners forum - TRS is at a loss as to the reason. In fact, when I pulled into the parking garage just this morning (lights set to 'auto') my left headlight failed to fire. :thumbdown:

I paid the extra money for the Morimoto kit because I thought it was going to be more reliable than my DDM HID fog light kit - both kits seem to be equally reliable whereas I experience similar problems with my DDM fog kit.
 

·
Registered
Joined
·
575 Posts
:nopics:
 
  • Like
Reactions: schoolcb

·
Registered
Joined
·
1,094 Posts
I too have the Morimoto kit (Morimoto mini projectors, bulbs, ballasts and relay harness), purchase from TRS, I've been running this kit for almost 2 yrs now.

I routinely have issues with either headlight randomly failing to fire/light at engine start-up esp when temps drop. After further research I have come to find out I am not alone - similar problems reported on the Porsche owners forum - TRS is at a loss as to the reason. In fact, when I pulled into the parking garage just this morning (lights set to 'auto') my left headlight failed to fire. :thumbdown:

I paid the extra money for the Morimoto kit because I thought it was going to be more reliable than my DDM HID fog light kit - both kits seem to be equally reliable whereas I experience similar problems with my DDM fog kit.
Do you have the relay harness? I had to add one to mine because the passenger side started doing that after 6 months or so.
 

·
Premium Member
Joined
·
267 Posts
Do you have the relay harness? I had to add one to mine because the passenger side started doing that after 6 months or so.
Yes, I have the relay harness. I called TRS last fall about my problem and all they said was try swapping the ballasts and bulbs (at the time only one light was affected, now it's either light so clearly not a bulb or one-off ballast issue).

Well after posting this and not being able to get my driver's side light to fire at all I contacted TRS again and they said there was a recall last year on my ballasts because of this very issue - first I heard of it. They offered to swap out my bulbs and ballasts under warranty - I just received the new units yesterday, so fingers crossed they work without issue. It's only a slight pain since I have to basically remove my lights to swap the bulbs.
 

·
Premium Member
Joined
·
267 Posts
I thought I would follow up on my above issues with the Morimoto kit. TRS sent me new ballasts (TRS states ballasts were improved because of this issue) and bulbs, so far so good, they have fired up every time. Now I just need to get the unreliable DDM fog ballasts replaced.
 
1 - 11 of 11 Posts
Top