Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Have not been able to find any install videos or photos for this filter. The trans oil external cooler hose on the radiator front would be the place to mount the filter. Which cooler hose is the intake and which one is the return hose?
 

Attachments

·
Premium Member
Joined
·
638 Posts
Just a guess but look for videos for tranny fluid change.
Some perform this by disconnecting the return line and allowing the torque convertor to fully drain.
So this is the line to install the filter, on the return line.
Also, consider the power steering reservoir.

Our Mercedes an old 300SD had a filter for the PS. then our 94' C280 also had filter for PS. So when I bought the 2003 Power Stroke I installed a magnafine filer for cooling system, PS and tranny. Weighing old versus new and taking them apart you can inspect them and see how well they work.

I say go for it.....and let us know how it's working our for you....
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks! What I really need to know is which line is the return line off of the Aux Trans Oil cooler. I know in my internet travels, I saw somebody who did this but can't remember where. Might have been just a description but no photos of the install. I may go by Toyota today and ask.
 

·
Registered
Joined
·
3 Posts
Hello I am installing this filter on my sequoia and have a question. Is the flow going up how this is positioned in the picture? I installed mine just like the picture with the arrow on the filter pointing up. I now have a mysterious leak of fluid somewhere I can't tell the source. I'm not sure if its transmission fluid or coolant. It's wet on the bottom of the radiator. Maybe radiator leaking? Hopefully not because I installed the filter incorrectly.
 

·
Registered
Joined
·
3 Posts
I think after further research I messed up with putting it in the wrong direction. The top is the return line and the filters flow arrow should be pointing down? It just didn't look that way in the photo here as it appeared the end of the filter with the lip was on top. But with it leaking some fluid now, I bet I messed up.
 

·
Registered
Joined
·
3 Posts
Here are some pics. I turned the filter around as I am sure it was going against the flow before. I looked at the fluid and its definitely coolant. Just don't know why it started leaking after I installed the filter backwards??? Do you think it blocked the flow of atf in the radiator and busted seals? Now do I have to worry about contamination? Also should I change the filter since it was installed backwards? Thanks!
 

Attachments

1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top