Toyota Tundra Discussion Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
There may be another thread about this already but has anyone had a humming/rattle when accelerating? Sounds like it’s from passenger side dash/glove box. I have tried to figure out what it is and no matter what I do can’t seem to get rid of it. I guess it’s my ocd but it’s all I can focus on and it’s driving me crazy, anyone got any ideas?
 

·
Registered
Joined
·
20 Posts
I had that too. Drove me nuts last summer on a road trip to Cali. Popped the bottom plastic cover off below the glove box (upper passenger footwell) and found peace on Earth at last! Just put it back on this past weekend with a piece of foam padding sandwiched in there and it's making that rattling sound again, just not quite as bad as it was. I think the tabs get worn and develop side play in their mounts. At least I know where it's coming from now. :nerd:
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks for replying, I’ll give that a try. I’ve never had so much trouble figuring out the cause of a noise. If I find it’s something different I’ll post it on here.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I had a chance to really look and figure out what it was today, it’s the ECM under the dash behind the glove box. I popped that big plastic piece off. Starting tapping on stuff til I heard it. I tried tightening the screws that I could reach but never helped. I put a C clamp on it and tightened it then drove around and there was no noise. Not a great permanent fix but at least I know what it is.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top