Toyota Tundra Discussion Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hey guys I have a 2012 cm rock warrior I've had it 10 months 17000 mi my battery just went bad anybody else have this happen just wandering if this was a widespread problem or if I just got a bad one thanks.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
20 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
70 Posts
Mine was still going strong from 07, only reason I replaced it was because I was tired of dealing with the corrosion. Probably just got a bad one.
 

·
F&@k Y'all, I'm from Texas
Joined
·
13,742 Posts
My battery lasted almost 5 years without a problem and then went South fast. Could be a bad bump that damaged a battery cell, could be a leaking battery, no telling without checking it. You could try the dealer and they might give you a free replacement.

Sorry I did not know this was the spelling test forum
If you want to communicate in written English, then learn to spell in English so that you can correctly communicate. "Wandering" and "wondering" have two completely different meanings.
 

·
Premium Member
Joined
·
920 Posts
On my 08 I had a bad corrosion problem from day one till I replaced it a few years ago. I discovered that the (j) clamp was tightened so tight that it had cracked the top just enough to cause it to corrode this was from the factory...so this my be what you are seeing...good luck!
 

·
Premium Member
Joined
·
3,151 Posts
If you want to communicate in written English, then learn to spell in English so that you can correctly communicate. "Wandering" and "wondering" have two completely different meanings.
the right forum would probably help too :dunno:
 
1 - 9 of 9 Posts
Top