Toyota Tundra Discussion Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter · #1 ·
I'm having issues with my HIDs not working after car washes. I have dielectric grease in all the connections and even put liquid electrical tape around the connections and they still go out. I have one ballast now that has not come back on since. The rest have come back. I am curious if coating the ballasts with plasti-dip is a good means of waterproofing them. It's just so frustrating running around with a light out. I bought the $30 eBay kits and they work fine until I go through the wash.

Sent from AutoGuide.com Free App
 
  • Like
Reactions: Mr. Creosote

·
Premium Member
Joined
·
8,115 Posts
Maybe buy the can and brush it on instead of the spray. I bet it would work great. Not sure how hot they get, you might only want to seal the joints, if I remember right, mine had a heat sink on one side.

 
  • Like
Reactions: Mr. Creosote

·
Registered
Joined
·
63 Posts
Discussion Starter · #4 ·
Because I already have plenty of plasti-dip and wanted to get it done now before it for wet again.
 
  • Like
Reactions: Mr. Creosote

·
Registered
Joined
·
63 Posts
Discussion Starter · #7 ·
I painted it earlier. I'll keep an eye on it and see how it does and if it does feel too hot at least I can just peel it off.
 
  • Like
Reactions: Mr. Creosote

·
Registered
Joined
·
176 Posts
Why are you having issues? Bad placement? I have had my ddms for about 2 months i guess and even after a few car washes, puddles and rain, i havent had an issue yet. I used di-electric grease on the connections and liquid tape on the wires going into the bulb. I have mine pretty protected from direct water contact however.
 
  • Like
Reactions: Mr. Creosote

·
Registered
Joined
·
2,327 Posts
Where do you have them mounted. Looking at doing mine this weekend and trying to find a good dry spot

Sent from AutoGuide.com Free App
 
  • Like
Reactions: Mr. Creosote
1 - 9 of 9 Posts
Top