Toyota Tundra Discussion Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
144 Posts
Discussion Starter · #1 ·
Hey guys. Haven't been on here in a while, been striper fishing the last nine days and am beat. Had my LRO kit installed a while back and an alignment. But looking at it from the rear it seems the rear tire and the front tire on the passenger side are not the same. Meaning the front tire is leaning out on the high side. Driver side looks fine. Do I need to find another alignment shop or is it just me or is this as close as it comes? I just hate to wear out my tires prematurely as I'm sure all of you know they are not cheap. Any input would be appreciated. Thanks. Chris
 

·
Premium Member
Joined
·
2,048 Posts
mmm I love striper fishing :D
 

Attachments

  • Like
Reactions: Wacked

·
Registered
Joined
·
144 Posts
Discussion Starter · #4 ·
Sorry forgot to add its a 2011 rock warrior D/C with the LRO kit and coaches 2 inch shackles. Now the UCA's are upper control arms correct? sorry. What kind and where do i purchase a set? Are they shorter than the stock ones? Just curious why just the passenger side looks out of whack. Thanks guys for any input.
 

·
Registered
Joined
·
1,201 Posts
Post up your alignment numbers. Do they look like what SoCal recommends or my alignment numbers posted in his stickied thread?
 

·
Registered
Joined
·
144 Posts
Discussion Starter · #7 ·
I actually parked my truck on my parents carport which is level and it looked fine. I guess my crappy driveway is uneven which made it look off. When I figure out how to post pics I will snap a photo of the alignment sheet and post them. I don't want to be "that guy" who has the little red X. I hate that too. Thanks for all your replays guys.
 
1 - 7 of 7 Posts
Top