Toyota Tundra Discussion Forum banner
1 - 19 of 19 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
So I just drove my 07 Double Cab Long Bed to a friends house 2 miles away. Everything was fine. Started it up 3 hrs later and drove it home. On the way noticed the 4 LO drive light was flashing, the VSC light was flashing, and the traction control light was on (2 swerving lines). The whole way. Turned it off at home and restarted it, same lights. Any idea what that means?? Truck was in 2wd at all times. No full throttle, no spinning tires... I did make a 3 point turn u-turn, not sure when the lights activated.

Bill
 

·
Registered
Joined
·
1,882 Posts
AIP failure, severed abs wire ? you install a lift lately ?
 

·
Registered
Joined
·
1,439 Posts
AIP pump unfortunately. Sounds like exactly what happened to me (Search a thread of mine from two days ago).

Took mine to the dealer and they replaced BOTH pumps and valves. Works well now and saved me $2,800. Toyota must have switched suppliers or reduced their costs.

Been in an area with a lot of moisture lately?

-rockstate
 

·
Registered
Joined
·
11 Posts
Mine was due to my cai with the pre oiled filter. Took mine to the dealer and replaced my maf sensor and something else under there. Saved me a hear attack and lots of $$$.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #5 ·
Everything is stock except at K&N filter installed 2 years ago. Humid climate as VA is, but nothing different than the last 4 years I've owned it. I only drive it about once a week now...today I drove it on 5 separate trips, all under 10 miles, no problems until now. I'm going to disconnect the battery tomorrow if it's still having problems to reset it, see what happens. Only 51k miles.
 

·
Premium Member
Joined
·
13,349 Posts
Had/may have AIP failure with secondary Valve stuck open. SInce I had to replace my positive terminal I haven't had the limp mode come on. I went to Advance Auto and used their scanner and read my codes and did research on codes. Knew the P2440 code was AIP failure. Currently at 156,700 miles.
 

·
Registered
Joined
·
2,901 Posts
An AIP failure is usually 4lo flashing, TRAC on, CEL on, and limp mode. Yours sounds slightly different so it could be a wheel sensor issue.
 

·
Premium Member
Joined
·
13,349 Posts
That's for OP. I don't have 4wd. Still OP should get the codes and go from there.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #9 ·
Just got scanned from Advance, they said its a valve stuck open on the AIP, I think he said secondary valve. I don't know anything about the AIP system, should I just take it to the dealer?
 

·
Registered
Joined
·
2,901 Posts
Just got scanned from Advance, they said its a valve stuck open on the AIP, I think he said secondary valve. I don't know anything about the AIP system, should I just take it to the dealer?
Yes, the '07 AIP system is covered by a 10yr/150k mile warranty and it is an expensive repair. Take it to the dealer and let them fix it. They should also supply you with a loaner car to drive while it is being fixed.
DO NOT clear the DTC code. It must be on when you take it in!
I just had mine done last week. They gave me a '12 Camry to drive while it was in the shop. All I had to do was refill the gas tank on the loaner.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #11 ·
Thanks everybody, taking it to the dealer on Thursday. They have to do their own diagnosis and vin check to make sure mine is covered, but also said he should have it done in 1 day. They will supply a rental if it is needed to be kept overnight. Thanks for all the input.

Bill
 

·
Registered
Joined
·
3,745 Posts
yup

Ooops, didn't refresh page and see you talked to the dealer.
 

·
Premium Member
Joined
·
13,349 Posts
Yes, the '07 AIP system is covered by a 10yr/150k mile warranty and it is an expensive repair. Take it to the dealer and let them fix it. They should also supply you with a loaner car to drive while it is being fixed.
DO NOT clear the DTC code. It must be on when you take it in!
I just had mine done last week. They gave me a '12 Camry to drive while it was in the shop. All I had to do was refill the gas tank on the loaner.
A little too late. I'm at 156k miles and I'm out of that coverage. Neither dealership wants to take and have it covered. So I won't used a dealership ever again.
 

·
Registered
Joined
·
85 Posts
AIP secondary valve issue..$2500+ fix.

It really is a shame they don't have a permanent fix for it. As long as there's water where you drive..those pumps will corrode quickly.
 

·
Premium Member
Joined
·
13,349 Posts
If I can't fix it today myself then it's time to go to the junkyard and find one. Since both dealerships I've been using for my maitenance want to put this under that coverage I will no longer use the dealership for my maintenance.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #17 ·
Well the dealership replaced the AIP in about half a day. No charge, all covered under the extended warranty. I asked about it happening again in another 5 years and the salesman stated that the new pump had a new design on it to prevent the moisture so it shouldn't happen again.

Hope he's right.

Thanks for all the replies.

Bill
 

·
Registered
Joined
·
2,901 Posts
Unfortunately the "new design" seems to have just as many problems as the "old design". When your 10yr/150k warranty runs out install an AIP bypass mod of your truck.
 
1 - 19 of 19 Posts
Top