Toyota Tundra Discussion Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hoping I can get some ideas here of where to go next with this. I had the recall work done on the air pumps and 2 years later they have failed again causing a p2433 code and limp mode. Installed the block off plates and bypass module and it's still in limp mode. Tried to have the codes cleared and nothing. Drove for a little bit and it went out of limp mode for a little bit then back in. Any ideas would be greatly appreciated. Thanks

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
77 Posts
My reading leads me to believe the same. The old flash only ran the truck from a cold start for ~30 seconds. It measured the intake air temperature to determine how cold it is outside. The bypass limited the low range, or flat out changed the intake temp to read a set number (I don't have one). But when the warranty work is done they reflash the ECU to run the pumps EVERY time the engine starts, regardless of what the temperature is. Temperature-trick-bypass won't work.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
Just left toyota dealer that did work and talked to tech that did my truck and said he did not flash it. What now??

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
313 Posts
Replacement of the secondary air injection components was a warranty enhancement and did not require a reflash as part of the procedure however there was a limited service campaign D0A and special service campaign F0A that was just the reflash. If either of those were done then it has the updated calibration. You can ask the dealer to run your vin to see if there are any open recalls or specifically if the D0A or F0A were done.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #6
That ran all service on it and nothing shows for any of this being done. I'm ready to pull my hair out!!! Could the module possibly be bad? Idk just trying to eliminate any possibility. If I decide to fix pumps does anyone have recommendations on where to buy and what exactly will all need be replaced? Pumps, valves etc...

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
313 Posts
Code P2433 is for the air pressure sensor and is not a code that will set when the pumps fail. The sensor is mounted directly on top of the switching valve and since I have never installed a by pass kit I do not know if the air switching valves are eliminated. I would hold off on replacing the pumps until you figure out exactly what is supposed to happen with the pressure sensor reading after the by pass kit is installed. Hopefully someone that has done one will chime in.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #11
Did you have the same code before you put they by pass kit in?
The first time it started going into limp mode I ordered the kit. I just hooked module up and all was good for a while but, check engine light came back on and it was still good for quite awhile even with light on. After almost a year it started going in and out of limp mode once in awhile then just recently was stuck and not coming out. So I tried to put the cut off plates in to see if that fixed the issue with no luck other than a couple times it came out of limp mode for maybe 30 secs. Then right back. I never read the codes until after I put the plates in which was 2 days ago.

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
313 Posts
So I did a little reading about the kits and it seems it still uses the pressure sensors so I'm thinking maybe there is a broken or chewed wire. A scan tool would be helpful at this point to check the voltage for the sensors. If it's fixed over 4.5 volts then it's probably an open in the wiring or sensor itself.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #13
So I did a little reading about the kits and it seems it still uses the pressure sensors so I'm thinking maybe there is a broken or chewed wire. A scan tool would be helpful at this point to check the voltage for the sensors. If it's fixed over 4.5 volts then it's probably an open in the wiring or sensor itself.
Excuse me for my ignorance but, what wires would I check? I'm pretty mechanically inclined but, I'm not the one that would be doing the work. My buddy will be who is a damn good mechanic. He is super busy so I'm trying to gather all info. I can myself. I would hate to order new valves and have him replace them and not fix the problem. I really appreciate all of your help

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
313 Posts
Excuse me for my ignorance but, what wires would I check? I'm pretty mechanically inclined but, I'm not the one that would be doing the work. My buddy will be who is a damn good mechanic. He is super busy so I'm trying to gather all info. I can myself. I would hate to order new valves and have him replace them and not fix the problem. I really appreciate all of your help

Sent from my SAMSUNG-SM-G928A using Tapatalk
It's no problem I'm happy to help any way I can. Just let me know what year and engine we're dealing with and I can get you all the diagnostic info you need.
 

·
Registered
Joined
·
313 Posts
The valves are located under the intake in the back but I think you might be able to get to the connectors. I would start by taking a look around there for rodent damage, they love that part of the intake.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #18
I should also note that truck won't idle on its own either. Idk if that the valves would cause this as well?

Sent from my SAMSUNG-SM-G928A using Tapatalk
 

·
Registered
Joined
·
93 Posts
Sounds like you have a separate issue to me. The mass airflow sensor bad?

I have a similar question but did not want to start a new thread. If this offends the OP, I will be happy start another...

At just under 80k my 2007 SR5 5.7 CM truck went into limp mode and the EPA BS induction pumps and valves needed changed. I have been reading about the DIY bypass and another person who sells PnP bypass kits on eBay. I tried one of the Ebay kits but the dashboard lights up like a Christmas tree! (traction control, 4Lo, check engine, etc.) I get a CEL of mass airflow sensor. I unplug, clear the codes and truck starts and runs fine. Plug the bypass back into the sensor and same thing happens and doesn’t want to run.

As I continue to do reading, it appears that the dealership not only replaces the pumps and valves but also reflashes the ECU, making the DIY bypass option not work. Is this correct?!? Is there now no way to disable this system or is another fix available?

My pumps and valves are working correctly, but I want to disable this system and never have to worry about this again. Any options?

Thanks for the input guys.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #20
Sounds like you have a separate issue to me. The mass airflow sensor bad?

I have a similar question but did not want to start a new thread. If this offends the OP, I will be happy start another...

At just under 80k my 2007 SR5 5.7 CM truck went into limp mode and the EPA BS induction pumps and valves needed changed. I have been reading about the DIY bypass and another person who sells PnP bypass kits on eBay. I tried one of the Ebay kits but the dashboard lights up like a Christmas tree! (traction control, 4Lo, check engine, etc.) I get a CEL of mass airflow sensor. I unplug, clear the codes and truck starts and runs fine. Plug the bypass back into the sensor and same thing happens and doesn’t want to run.

As I continue to do reading, it appears that the dealership not only replaces the pumps and valves but also reflashes the ECU, making the DIY bypass option not work. Is this correct?!? Is there now no way to disable this system or is another fix available?

My pumps and valves are working correctly, but I want to disable this system and never have to worry about this again. Any options?

Thanks for the input guys.
I wish it was just the mass sensor. That would be to easy...lol. I'm getting p2433 code.

Sent from my SAMSUNG-SM-G928A using Tapatalk
 
1 - 20 of 20 Posts
Top