Toyota Tundra Discussion Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
New to the forum and have read past comments here on this issue. I started w/ a P2443 code. Dealer wanted 2k to fix I said no and no warranty cov. w/92k miles. So I installed a bypass kit from RUTECHSOLUTIONS and it worked for 6 days. Then I get chk eng, 4x4, and traction control lights w/ a p0116 code. RUTECH had be unplug their kit and start w/ the old OEM. No lights for 4 days then it came back. I cleaned the MAF sensor and again no problems for 3 days then lights came back. Is the kit bad? I find it hard to believe I developed a new problem in 6 days.
 

·
Registered
Joined
·
475 Posts
I was under the impression that the bypass only works if the aip was in working condition when you bypass it. Not positive but something about when it fails, it fails and n the wrong position. Closed or open I don't know which. And then I remember possibly once the aip is replaced the bypass won't work for some reason.

This is just my vague memory on this so don't quote me. Just trying to point you in the direction of aip and bypass research.
 

·
Registered
Joined
·
19 Posts
Check on warranty enhancement ZG6, it extends to 2011 model 10 years/100,000 miles for air pumps and valves. I just got notice a couple of weeks ago, already fixed out of pocket, I will see if they will pay. gave me a case number. good luck!
I received the check from Toyota yesterday for the full amount of repairs $1554.00! Glad they stepped up and took care of my 2011.
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top