Toyota Tundra Discussion Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Recently I purchased an aFe Performance Dry S air filter. Got a 2 MPG improvement (forgot to take pics for proof). Though there weren't instructions, still was an easy install.

If you're nervous about spending the big bucks on a CAI I definitely recommend getting the aFe air filter.
 

·
Registered
Joined
·
132 Posts
I had an aFe CAI on my old Silverado, I liked it.
 

·
Registered
Joined
·
315 Posts
The OP is talking about just the air filter right? Not a full CAI I believe. Last time I called to get the filter I almost got sold the whole CAI but I backed out and just removed the carbon filter instead.
 

·
"Resident Liberal"
Joined
·
12,231 Posts
I would leave my Afe on even if I lost 2mpg. I looks so cool and sounds so badass.

:woot:
 

·
Registered
Joined
·
13 Posts
Ordered an AFE today to supplement my MBRP Exhaust (split rear side exits in T409) I also ordered today :)

I'll post my thoughts on each once installed.
 

·
Registered
Joined
·
46 Posts
After reading reviews, on K&N, AFE, and Volant. I purchased the AFE Cold Air Intake System Stage 2 Si for my 2010, should be here by the weekend, will update on results.
 

·
Registered
Joined
·
8 Posts
How much do these AFE's cost for the 5.7L 2010? What is a good price? For those that have these installed how bad is the whistle or is there any additional motor noise when idling or during regular driving? Also what kind of fuel effeciency are people seeing?
 

·
Registered
Joined
·
184 Posts
Not sure if you saw my post but be careful if you do purchase the AFE CAI. Mine was not drilled all the way through from the vacuum hose. It ended up causing a loud noise/squeeking. The mech said it was causing a negative vacuum in the crankcase. I am happy with my CAI now but that could have been a serious problem if it wasn't identified.
 

·
Registered
Joined
·
453 Posts
Bopitz,

After reading your post about the vacuum tube, I was feeling a bit paranoid about mine, so I went out, and low and behold, the thing was barely drilled thru. I took the intake tube off and hollowed it out a bit more, just to be safe. Man, I wonder what kind of QC these things go thru?
 

·
Registered
Joined
·
107 Posts
I just got mine in tonight---No whistle sounds bad ass
 

·
Registered
Joined
·
3,418 Posts
i think i'm gonna pick up the filter only, thanks for posting this, now, onto the big question, who's got the best deal on them??
 

·
Registered
Joined
·
156 Posts
I have the aFe Pro Dry on my 02 4.7. The engine has pinging problems ever since it was installed. We've checked everything--mass air sensor, fuel pump--everything is fine. Air/fuel is lean. Even aFe cant figure it out
 

·
Registered
Joined
·
26 Posts
I have one I'll sell you cheap with a brand new cleaning kit included. I took it off my truck after I found some leakage around the corners of the filter. I was having issues of the truck reving to over 2000 rpm on start up and couldnt figure out anything. I was using the AFE drop in with the TRD cold air intake. Installed both the intake and filter at the same time. Shortly after install, the higher than normal cold start reving started. I ended up taking off the intake, thinking that was the issue, but left the AFE filter in the stock housing. Problem went away for a while then returned. Finally found where you could see dust getting around the corners of the filter. Installed factory air filter, cleaned MAF and everything has been back to normal for last six months. The AFE media seems great, but they dont use a very soft/pliable rubber where it seals against the filter housing. Do some google searches and you will find this seems to be an issue with some AFE drop in models. Just my experience.
 

·
Registered
Joined
·
3,418 Posts
I have one I'll sell you cheap with a brand new cleaning kit included. I took it off my truck after I found some leakage around the corners of the filter. I was having issues of the truck reving to over 2000 rpm on start up and couldnt figure out anything. I was using the AFE drop in with the TRD cold air intake. Installed both the intake and filter at the same time. Shortly after install, the higher than normal cold start reving started. I ended up taking off the intake, thinking that was the issue, but left the AFE filter in the stock housing. Problem went away for a while then returned. Finally found where you could see dust getting around the corners of the filter. Installed factory air filter, cleaned MAF and everything has been back to normal for last six months. The AFE media seems great, but they dont use a very soft/pliable rubber where it seals against the filter housing. Do some google searches and you will find this seems to be an issue with some AFE drop in models. Just my experience.
pm me please :D
 
1 - 19 of 19 Posts
Top