Toyota Tundra Discussion Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6,440 Posts
Discussion Starter #1
I bought a pair of 5100's for my base truck. While having the frame replaced, I decided to let the dealer mount them.
But they could not as the bottom mount would not fit the spring.
Has anyone with a non TRD run into this?
I ended up with buying complete strut assy due to time and am deciding if I want to go with the 5100's or just stick with what I got.
 

·
Premium Member
Joined
·
4,002 Posts
5100 use the OEM spring, several members here have them.
Perhaps the dealer had spring mount upside down...:facepalm:


All 2007 and up use the same shock.
Is your truck earlier than a 2007?

I'm running 6112s on my non TRD 2014 SR5....
 

·
Registered
Joined
·
55 Posts
Sounds like your dealer was putting them together incorrectly, maybe upside down...IDK. As the last poster said they use the stock springs with an adjustable bottom spring plate and mount to the truck like any other strut assembly. Maybe they had the spring reversed and/or the bottom spring plate upside down...
 

·
Registered
Joined
·
6,440 Posts
Discussion Starter #4
I picked up new strut assy and brought them there when they ran into the problem. The bottom of the spring was too small to go over the bottom plate. Maybe I got the wrong plates.
I don't have TRD so I think the base springs that come on the black shocks are built differently. I have the original struts.
Has anyone got a pic of the bottom of their TRD springs so I could compare.
 

·
Premium Member
Joined
·
4,002 Posts
I picked up new strut assy and brought them there when they ran into the problem. The bottom of the spring was too small to go over the bottom plate. Maybe I got the wrong plates.
I don't have TRD so I think the base springs that come on the black shocks are built differently. I have the original struts.
Has anyone got a pic of the bottom of their TRD springs so I could compare.
I don't think that TRD, or lack thereof, is the problem.
I've never seen that the 5100 MUST REPLACE TRD SHOCKS..

Either the mounting plate is upside down, the spring is upside down, or you were sent the wrong shocks.

I wish I could help more but I have 6112s.

@dirtydeeds do you have any input?
 

·
Registered
Joined
·
7,145 Posts
I don't think that TRD, or lack thereof, is the problem.
I've never seen that the 5100 MUST REPLACE TRD SHOCKS..

Either the mounting plate is upside down, the spring is upside down, or you were sent the wrong shocks.

I wish I could help more but I have 6112s.

@dirtydeeds do you have any input?
These statements sound reasonable. Black shocks and yellow trd have same size springs.
 
1 - 6 of 6 Posts
Top