Toyota Tundra Discussion Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have 2011 Tundra SR5 Leveled and recently my right side rack and pinion seal blew and threw fluid all over the right wheel well and parts. I have since replaced the Rack and pinion. Now my 4hi light is blinking ant the TPMS shows low air. The TPMS came on after the oil flung everywhere. 4 hi Blinking happened after replacement of rack. None of my others lights are flashing though. Truck is in 2wd and there are no strange sounds or vibrations. Also the 4wd does not engage when switching from 2wd to 4hi or 4 lo. So is this an ABS issue. Please any help would be great.
 

·
Registered
Joined
·
13,524 Posts
The tpms should not be tied into the 4wd system at all, especially considering 4wd works without issue when aired down.


I would suspect there is a damaged abs/wheel speed sensor.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The tpms should not be tied into the 4wd system at all, especially considering 4wd works without issue when aired down.


I would suspect there is a damaged abs/wheel speed sensor.
I agree with Powertech2. They're easy to damage and can cause all kinds of crazy things. You need to pull your codes.
Thank you guys for the input I have taken it over to a local shop that is certified to pull the abs codes. Hopefully that is what happened. Between pulling the Rack and Pinion and covering the right side with hydraulic fluid when it blew up I'm sure something sensor related happened.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Update... the shop ran the ABS codes found out that the plug for the sensor at the frame was malfunctioning. Mechanic replaced the connector only and works like a champ. Only charged me 85 for the scanning and repair. Cannot complain at all.
 
1 - 5 of 5 Posts
Top