Toyota Tundra Discussion Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
2018 Toyota Tundra Platinum. Had tires swapped out at Costco little over a week ago, and now the TPMS light flashes for a minute when the vehicle is turned on and then stays on. Owner's manual says to initialize again, but after I turn on the vehicle and hold that button on the lower dash the light never blinks. I get zero response. What am I doing wrong?

I understand Toyota changed sensors somewhere around 2018; wonder if technician put in incorrect type.....
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Why would he have changed the sensors the truck came in with????
Oops, I missed that detail. They broke one of them while putting the new tires on so they replaced it.

I actually took the truck buy another tire shop today and they attempted to read the codes from each of the wheels. The one that Costco broke and replaced is actually not compatible with the truck. Followed up with Costco and they offered to replace it with the correct one free of charge. Bringing it back to them soon. Case closed.
 

·
Registered
Joined
·
2 Posts
I am having the same issue. DT broke one of mine and tried to use an aftermarket one but it wouldn’t work. Then they swapped it with a factory sensor twice. After about 50-100 miles the sensor light comes back on. Took it to 2 different Toyota dealers and they reset/reprogrammed them but after about 100miles light comes back on. They tell me they don’t know what it could be.. did you have any luck with yours?
 

·
Registered
Joined
·
23 Posts
Discussion Starter #5
I am having the same issue. DT broke one of mine and tried to use an aftermarket one but it wouldn’t work. Then they swapped it with a factory sensor twice. After about 50-100 miles the sensor light comes back on. Took it to 2 different Toyota dealers and they reset/reprogrammed them but after about 100miles light comes back on. They tell me they don’t know what it could be.. did you have any luck with yours?
Sorry for the late response, but yeah. As soon as Costco threw in the correct one that I procured from the dealership it was immediately good. I've driven it over a thousand miles since and it is breaking great.
 
1 - 5 of 5 Posts
Top