Toyota Tundra Discussion Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello,
I pulled the engine on my 2012 Tundra and rebuilt it, but after reinstalling the engine, I am left with a mysterious plastic part. I am not sure if it attaches to the manifold or maybe the cowl top wiper motor area (removed to get engine out). Any ideas??? Also, the part seems to be stamped with the number PA66 2R5Z-0 or PA88 2R5Z-0.
887008
887009

887010
 

·
Registered
Joined
·
834 Posts

·
Registered
Joined
·
250 Posts
First post needs a hearty welcome.. Welcome.
 

·
Registered
Joined
·
7 Posts
Plastic piece at starter? What did you use for lift points on the motor when you pulled it? Im pulling one this weekend.

Sent from my SM-T500 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Plastic piece at starter? What did you use for lift points on the motor when you pulled it? Im pulling one this weekend.

Sent from my SM-T500 using Tapatalk
Oh well, if it is from the starter, I didn't use it and the truck starts fine. 😁. Do you have a picture of it on a starter.? Per question regarding pulling the engine, I pulled the engine without the transmission (easy that way). I used sling around engine but there are 2 bolt holes between the manifold and cylinder (see toyota service manual)
 

·
Registered
Joined
·
7 Posts
It wouldnt effect the starter it just leaves a gap that would let crap in. Any have a pic of the service manual??

Sent from my SM-T500 using Tapatalk
 

·
Registered
Joined
·
7 Posts
It wouldnt effect the starter it just leaves a gap that would let crap in. Anyone have a pic of the service manual??

Sent from my SM-T500 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
It wouldnt effect the starter it just leaves a gap that would let crap in. Anyone have a pic of the service manual??

Sent from my SM-T500 using Tapatalk
Motor vehicle Automotive design Automotive exterior Font Automotive wheel system

Toyota sells brackets, didnt want to spend money on them.
 

·
Registered
Joined
·
7 Posts
Question how did you prime the oil in for first start. I picked up a reman and im about to set it in

Sent from my SM-T500 using Tapatalk
 
1 - 11 of 11 Posts
Top