Toyota Tundra Discussion Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings all. This is second 06 Tundra I've owned that had this issue. First time I had no choice but to take to Toyota Service center for repair and $2600+ dollars and many Secondary Air system parts later it was good to go. Now on my second 06 Tundra and having same symptoms with P2440 code. So this time I tore into it, replaced SAS air pump, Diverter valve and both control/check valves. No help. Anyone have any ideas?? Thanks a million.
 

·
Registered
Joined
·
12 Posts
Greetings all. This is second 06 Tundra I've owned that had this issue. First time I had no choice but to take to Toyota Service center for repair and $2600+ dollars and many Secondary Air system parts later it was good to go. Now on my second 06 Tundra and having same symptoms with P2440 code. So this time I tore into it, replaced SAS air pump, Diverter valve and both control/check valves. No help. Anyone have any ideas?? Thanks a million.
Did you disconnect the battery to clear the code?
I just replaced my diverter valve and disconnected the battery for 5 minutes and all is well. Note I tested the pumps in place to make sure that they are fine. Note you may want to upgrade the SAIS Intake “trumpets”. Toyota redesigned them; not sure when. The new style is $30 from https://parts.diamondtoyota.com. (I hope it is ok to say that) They were very responsive and prices were the best I found on the net.

Oops I just noticed that you said 4.7 and I have 5.7 but same principle.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top