older model roadmasters - TundraTalk.net - Toyota Tundra Discussion Forum

User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 09-14-2016, 05:49 PM Thread Starter
Senior Member
 
volleyball's Avatar
 
Join Date: Feb 2009
Location: Albany, NY
Posts: 6,441
Thanks: 155
Thanked 2,946 Times in 1,821 Posts
Mentioned: 13 Post(s)
Tagged: 0 Thread(s)
Quoted: 584 Post(s)
(Thread Starter)
older model roadmasters

Years ago before I purchased a set of roadmasters, I had contacted your company and was told there was no 2nd gen Tundra kit. And to use a kit designed for a dodge.
It was item 2458 MK II - XXDDF.
Several surgeries later I am ready to install. I see that there is now a Tundra kit. The brackets look different.
I am wondering what to do? The kit I have is still new and unused. If i should use the old kit there was something different that I was suppose to do which of course I have forgotten.
Should I get updated parts?
volleyball is offline  
Sponsored Links
Advertisement
 
Reply

  TundraTalk.net - Toyota Tundra Discussion Forum > Vendors > Roadmaster Active Suspension

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the TundraTalk.net - Toyota Tundra Discussion Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome